Пользователи ИБ

Получает таблицу пользователей информационной базы, со всеми возможными свойствами.
Контекст:Встроенный язык

Выражение на встроенном языке

ТЗ=Новый ТаблицаЗначений();

ПользователиИБ=ПользователиИнформационнойБазы.ПолучитьПользователей();

Свойства=Новый Структура("АутентификацияОС,АутентификацияСтандартная,ЗапрещеноИзменятьПароль,Имя,

|ОсновнойИнтерфейс,Пароль,ПарольУстановлен,ПоказыватьВСпискеВыбора,ПолноеИмя,

|ПользовательОС,Роли,РолиСтрокой,УникальныйИдентификатор,Язык");

Для Каждого Эл из Свойства Цикл

    ТЗ.Колонки.Добавить(Эл.Ключ);

КонецЦикла;

Для Каждого Эл ИЗ ПользователиИБ Цикл

    Стр=ТЗ.Добавить();

    Для Каждого ЭлСтр ИЗ  Свойства Цикл

        Попытка

            Ключ=ЭлСтр.Ключ;

            Если Ключ="РолиСтрокой" Тогда

                Зн="";

                Для Каждого ЭлРоль ИЗ Эл.Роли Цикл

                    Зн=Зн+?(Зн="", "", ";")+ЭлРоль;

                КонецЦикла;

            Иначе

                Зн=Эл[Ключ];

            КонецЕсли;

            Стр[Ключ]=Строка(Зн);

        Исключение

        КонецПопытки;

    КонецЦикла;

КонецЦикла;

Результат=ТЗ;


Comments